Current User: Guest Login
Please consider registering


Lost Your Password?

Search Forums:


 






Minimum search word length is 4 characters – Maximum search word length is 84 characters
Wildcard Usage:
*  matches any number of characters    %  matches exactly one character

methodurl problem… any help

Reply to Post Add a New Topic
UserPost

12:47 pm
June 16, 2008


r3dn3ck

New Member

posts 2

The string below is a sanitized excerpt from my web logs. Using Apache 2 and Tomcat 5 to serve various content as a resource for other sites. When I try to import my logs into awstats it pukes on the LogFormat. I know my LogFormat is correct in what fields I'm selecting (not a n00b) and I've managed to even massage the log data to narrow the problem down to a specific handling of my %methodurl field. It seems that the way we include the referrer URL and query string in the GET (this is done for a reason so it can't be changed) breaks awstats ability to parse that field.

Here's a single line example:

"GET /Syndicate/SynMaster?ttpid=TTPID-E6-106
&vsr_sku=541162244&vsr_price=1.99&vsr_shoppi
ng_cart=http%3A//www.somedomain.com/webapp/w
cs/stores/servlet/OrderItemAdd%3FURL%3DOrder
ItemDisplay%26catEntryId_0%3D13002850%26quan
tity_0%3D1&ParentUrl=http%3A//www.somedomain
.com/product/541162244.htm HTTP/1.1"

Ok, short of deleting everything after …ttpid=TTPID-E6-106 (which I did and it worked sparklingly well) is there any way anyone can figure of getting updateall.pl now to not error out on my logformat?

If I'm just not using the correct search term in google please feel free to tell me what search term you've found helpful for this case and I'll go do my homework. 2 days of searching has yeilded exactly what I have now.

Thanks chaps.

1:23 pm
June 16, 2008


Jean-Luc

Admin

posts 1125

Hi,

I added your %methodurl  in a sample log file and run the AWStats update and your very long URL was visible in the AWStats report.

I do not know your updateall.pl  which is not part of the AWStats software distribution.

1:49 pm
June 16, 2008


Jean-Luc

Admin

posts 1125

I repeated the test with awstats_updateall.pl  (included in the AWStats distribution) and I get the same result.

4:19 pm
June 16, 2008


r3dn3ck

New Member

posts 2

K… that's bizarre. I went and did a quick awk against the log file to strip out basic data needed for format 4 similar to:

xxx.xxx.xxx.xxx – - [02/Jun/2008:00:00:02 +0200] "GET /Syndicate/SynMaster-hippies-91ECXO-39318 HTTP/1.1" 200 286

and set LogFormat for 4, ran the update and it drank it in. It appears that I can get away with pre-processing the logs prior to loading them into AWstats for the time being. It's still optimal that I not have to bother with the pre-processing via awk. Is there a mechanism that I can use to send you an unsanitized log snippet and have you try it out and see if it works?

In the meantime, I'm off and looking at long url handling.

2:50 am
June 17, 2008


Jean-Luc

Admin

posts 1125

r3dn3ck said:

Is there a mechanism that I can use to send you an unsanitized log snippet and have you try it out and see if it works?


I sent you an email.

Reply to Post

Reply to Topic:
methodurl problem… any help

Guest Name (Required):

Guest Email (Required):

NOTE: New Posts are subject to administrator approval before being displayed

Smileys
Confused Cool Cry Embarassed Frown Kiss Laugh Smile Surprised Wink Yell
Post New Reply

Guest URL (required)

Math Required!
What is the sum of:
1 + 1
   


About the InternetOfficer.com Forum

Forum Timezone: UTC 1

Most Users Ever Online: 302

Currently Online:
10 Guests

Currently Browsing this Topic:
1 Guest

Forum Stats:

Groups: 2
Forums: 9
Topics: 638
Posts: 2712

Membership:

There are 257 Members
There have been 305 Guests

There is 1 Admin
There is 1 Moderator

Top Posters:

cssfsu – 55
deepakgupta – 34
albert_newton – 30
cosminpana – 20
DTNMike – 19
ahtshun83 – 17

Recent New Members: raju, todd2taylor, sbdcunha, mansigill1987, ThomasDuh, ThomasKic

Administrators: Jean-Luc (1125 Posts)

Moderators: Jean-Luc (1125 Posts)