Current User: Guest Login
Please consider registering


Lost Your Password?

Search Forums:


 






Minimum search word length is 4 characters – Maximum search word length is 84 characters
Wildcard Usage:
*  matches any number of characters    %  matches exactly one character

Permission problems with AWStats

Reply to Post Add a New Topic
UserPost

4:35 am
May 4, 2008


Steve

Aus

Member

posts 14

Hi again,

I have followed the guide once again by Simon Schofield

http://www.ihsen.com/support/InstallingAWStatsOnIIS6.pdf

Installed as per guide and run Step 11 -Testing and Finishing with similar results.

The problem now is I receive a page can not be found 404 error when typing the following

http://statistics.mydomain.com/cgi-bin/awstats.pl?config=MyWebsite

I have added a file to http://statistics.mydomain.com/cgi-bin/test.txt which opens fine.

Adding awstats.pl to the documents tab of the cgi-bin directory didn’t help.

I’m not sure what permissions to allow for awstats.pl as it is now read only.

I would really appreciate some assistance

5:10 am
May 4, 2008


Jean-Luc

Admin

posts 1125

Please double-check the instructions in step 6. Is there any difference between your setup and the recommendations in the PDF document ?

I looked at your previous topic in the forum and I have two more questions to understand how far you reached:

  • what do you get when you run awstats.pl from the command line as indicated in the beginning of step 11 ?
  • what happens when you go to http://statistics.mydomain.com/cgi-bin/awstats.MyWebsite.conf ?

5:44 am
May 4, 2008


Steve

Aus

Member

posts 14

Hi Jean-Luc

Instructions in step 6 look identical.

Prevoius forum topics a little different. I completely removed AWStats and started over again.

Question1 – what do you get when you run awstats.pl from the command line as indicated in the beginning of step 11 ?

Phase 1 : First bypass old records, searching new records…..

Phase 2 : Now process new records

Jumped lines in file: 0

Jumped lines in file: 38

Found 1 dropped recors,

Found 3 corrupted records,

found 0 old records,

found 34 new qualified records.

Question 2 – what happens when you go to http://statistics.mydomain.com/cgi-bin/awstats.MyWebsite.conf ?

404 error page can not be found.

Thanks again

7:44 am
May 4, 2008


Steve

Aus

Member

posts 14

Jean-Luc,

I believe i have a problem with the perl extension in IIS6.

I tried the following with the same 404 error.

http://support.microsoft.com/kb/245225

I also noticed that i don't have an option for “Perl CGI Extension – Allowed” within my Web Service Extensions. I have only “All Unknown CGI Extensions – Prohibited”.

10:49 am
May 4, 2008


Jean-Luc

Admin

posts 1125

Steve,

Your AWStats website directory is named C:\\InetPub\\wwwroot\\statistics or something similar. Are its permissions set for "read", "script" and "execute" ? Same question for the subdirectory where awstats.pl is located if it is a subdirectory.

My understanding is that the "Perl CGI Extension" option should become visible at the time you install Perl.

Please double-check the path to perl.exe (as specified in step 4).

Is the .pl extension in the list in step 5 ? If it is not, add it exactly as specified.

1:20 am
May 5, 2008


Steve

Aus

Member

posts 14

Both AWStats directrory and the cgi-bin directory have “read” and “script and executable” permission.

The Perl CGI Extension doesn't show as a web service extension only

Perl-Allowed is in the web service extension list.

The path 2 the perl.exe within the website/mappings tab is as follows

.pl is the extension and the path is c:\\Perl\\bin\\perl.exe. “%s” %s

There is no .cgi extension listed anywhere in the mapping table.

When I get double click Perl under Web Service Extensions the required fields tab is listed as c:\\Perl\\bin\\perl.exe “%s”

There is both a perl.exe and a perl5.6.1 exe in the perl\\bin, not sure if i should be using the 5.6.1?

I tried serveral different permission but still get the 404 error.

I also removed the awstats.pl from the website/document tab as that also appeared to make no difference.

4:18 am
May 5, 2008


Jean-Luc

Admin

posts 1125

Perl 5.6.1 is an old release. This can be the reason why the Web Service Extensions are not as described in the documentation. I am not sure whether you need both "Perl" and "Perl CGI Extension" in order to run AWStats.

I believe that the "Executable path" in step 5 should be exactly the same as the "Path to file" in step 4. This should be corrected.

Did you restart IIS after making the changes ? To restart IIS, go to "Control Panel", then "Administrative Tools", then "Services" and, from "IIS Admin Service", click "Restart".

7:38 am
May 5, 2008


Steve

Aus

Member

posts 14

Restarted IIS but still no luck.

Perl just doesn't appear to be configures correctly for IIS.

I have tested a few basic scripts and they all fail.

Guess I need to delete the .pl mapping and the Perl web service extension and try again.

Thanks

I think I might remove the old perl installation and install 5.8 or 5.10.

Update : I have installed activeperl 5.10 and can now run .pl script from my virtual directory in IIS.

5:12 am
May 6, 2008


Steve

Aus

Member

posts 14

Jean-Luc

I feel like jumping over the moon.

I finally have an AWStats statistics page for my website.

Thank you for your patience as it was a very long road.

I guess the new active perl done the trick.

Thank You

Reply to Post

Reply to Topic:
Permission problems with AWStats

Guest Name (Required):

Guest Email (Required):

NOTE: New Posts are subject to administrator approval before being displayed

Smileys
Confused Cool Cry Embarassed Frown Kiss Laugh Smile Surprised Wink Yell
Post New Reply

Guest URL (required)

Math Required!
What is the sum of:
5 + 4
   


About the InternetOfficer.com Forum

Forum Timezone: UTC 1

Most Users Ever Online: 302

Currently Online:
11 Guests

Currently Browsing this Topic:
1 Guest

Forum Stats:

Groups: 2
Forums: 9
Topics: 638
Posts: 2712

Membership:

There are 257 Members
There have been 305 Guests

There is 1 Admin
There is 1 Moderator

Top Posters:

cssfsu – 55
deepakgupta – 34
albert_newton – 30
cosminpana – 20
DTNMike – 19
ahtshun83 – 17

Recent New Members: raju, todd2taylor, sbdcunha, mansigill1987, ThomasDuh, ThomasKic

Administrators: Jean-Luc (1125 Posts)

Moderators: Jean-Luc (1125 Posts)