Current User: Guest Login
Please consider registering


Lost Your Password?

Search Forums:


 






Minimum search word length is 4 characters – Maximum search word length is 84 characters
Wildcard Usage:
*  matches any number of characters    %  matches exactly one character

plugin configuration

Reply to Post Add a New Topic
No Tags
UserPost

9:21 am
December 3, 2010


moyakiki

Guest

Jean-Luc

Should I just copy a file (follow_me_by_internetofficer.pm) to path (\cgi-bin\plugins\) and add a LoadPlugin section in my configuration file

Like this?

# Plugin: FollowMe
# Perl modules required: None
# Adds click path analysis to AWStats.
#
#LoadPlugin="follow_me_by_internetofficer"

I did it, but I couldn't see any new things in my awstats pages

I need more information about configurating this plugin. So, Could you let me kmow more information about it?

Thank you.

JE.

9:35 am
December 3, 2010


Jean-Luc

Admin

posts 1125

Hi moyakiki,

For a basic installation, you just need to add

LoadPlugin="follow_me_by_internetofficer"

in your AWStats config file (note that there is no # in the beginning of the line).

When this is done, you get a new column called "Follow Me" in the "Hosts (Top 10)" section.

Installation instructions are explained under Follow Me Plugin Installation.

10:00 am
December 3, 2010


moyakiki

Member

posts 3

Sorry, I just found my mistake.

And now, I can see the 'Follow me' column in the host list.

But, When I click the 'zoom' link, there's no record in every hosts.

and I've got an error message like this:

Error: Couldn't open server log file "\tools\logresolvemerge.pl  \Log\mysite01\101202.log Log\mysite02\101202.log |" : Bad file descriptor

I think, it seems can not load a log file which is merged with logresolvemerge.pl in the config file.

Is it right? Is there any method which can solve this issue?

 

And it seems that show an analysis report by host. So, I should click every zoom links of hosts.

Is it provides any integrated page in this plugin?

I think, it can be better if it provides a kind of integrated page which can show by all of hosts.

Or providing analysis reports by pages may be also good.  

 

Thanks.

JE.

10:44 am
December 3, 2010


Jean-Luc

Admin

posts 1125

The FollowMe plugin is compatible with logresolvemerge.pl.

It is hard to tell from where your "Bad file descriptor" error is coming: didn't you forget a backslash before Log\mysite02\101202.log ? In the worst case, "Bad file descriptor" can come from a corrupted file system.

6:08 am
December 6, 2010


moyakiki

Member

posts 3

Jean-Luc,
 

 
 

I've checked the error message. And there's no problem in the path of log file such as forgetting backslash. 
 

But, I've found an another message like this:

Setup ('C:\Web\AWStats\cgi-bin/awstats.my-web-site.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).

 

The correct absolute path is "C:\Web\AWStats\cgi-bin\awstats.my-web-site.conf"

And the FollowMe plug-in is in "C:\Web\AWStats\cgi-bin\plugins"

I think, it looks like a problem about the relative path.

But, it was no problem when I updated aswstats in command prompt.

So, I think there's an another way to configurate a path for plugin.

Where can I correct this problem?

 

Thank you for your replies.

JE.

10:33 am
December 6, 2010


Jean-Luc

Admin

posts 1125

Did you try to replace the relative path by the absolute path ? I expect that this will make the plugin work for you.

I do not recommend the use of relative path in AWStats in general, as, in many configurations, the relative path is different from the browser and from the command prompt (depending on how awstats.pl is called).

3:56 am
December 7, 2010


moyakiki

Member

posts 3

Hi,

 

Actually, I didn't use the relative path in my config file. I'm using the absolute path.

When I found the second error message, I thought I can replace a slash by a backslash in the perl scripts if there's an configuration code  using a slash in front of my config file name in the perl scripts.

 

So, I've tried to find them and I modified the perl scripts awstats.pl.

The config file path have no wrong thing in the error message now.

But, It still dosen't work. It still shows me same error messages.

And there's  no error when I remove the logresolvemerge.pl in my config file. It just showed nothing.

 

I really don't get it why.

In addition, is there any possibility this is all because of the mismatching the log file format?

 

Thanks.

JE.

9:54 am
December 7, 2010


Jean-Luc

Admin

posts 1125

Hi,

Error: Couldn't open server log file "\tools\logresolvemerge.pl  \Log\mysite01\101202.log Log\mysite02\101202.log |" : Bad file descriptor

means that AWStats cannot read the log files. If it cannot read the files, it does not know what their format is. So it cannot be a log format issue at this point. That said, note that

LogFormat=2

is not compatible with logresolvemerge.pl.

I am convinced that there is no need to modify the awstats.pl script and that there is no problem caused by the use of a / in place of a \ in the AWStats message.

To precisely identify the problem, I suggest that you add a second config file where you have:

LogFile="\tools\logresolvemerge.pl \Log\mysite01\101202.log \Log\mysite02\101202.log | "
AllowToUpdateStatsFromBrowser=1

Then click the "Update now" link at the top of the AWStats report. Does it perform the update of the stats ? Do you get any error message ?

As you see, the FollowMe plugin is not used in this test. the goal of the test is to check if the path to the log files is okay for AWStats.

If this does not help, feel free to email us ( awstats@internetofficer.com ) a copy of your config file and of two of your log files and we will try it here on a Windows platform.

9:34 pm
December 13, 2010


Jean-Luc

Admin

posts 1125

Hi moyakiki,

You wrote: "When I click the 'zoom' link, there's no record in every hosts. "

Version 1.10 of the plugin is now available for download. It is a slightly modified version of the original plugin. When no relevant data is found in the parsed log files for the given IP address, a clarification message is generated. Let us hope that this helps understand what happens in your setup.

12:24 pm
August 31, 2012


Fooligan

New Member

posts 1

I've just setup the "reffering domain" and "follow me" plugins. The "reffering domain" plugin works as expected, however the "follow me" pluging gives me:  "Error: Couldn't open server log file "/var/log/apache2/boeken.tazzmania.nl-access" : Permission denied" when I hit the zoom button.

I run this on a Gentoo server with Apache vhosts enabled, and have sepparate logfiles (/var/log/apache2/*.tazzmania.nl-access and /var/log/apache2/*.tazzmania.nl-error) for each vhost (the * is replaced with the name of the vhosts for each log)

None of the other plugins seem to have this permission problem. What am I doing wrong?

No Tags
Reply to Post

Reply to Topic:
plugin configuration

Guest Name (Required):

Guest Email (Required):

NOTE: New Posts are subject to administrator approval before being displayed

Smileys
Confused Cool Cry Embarassed Frown Kiss Laugh Smile Surprised Wink Yell
Post New Reply

Guest URL (required)

Math Required!
What is the sum of:
8 + 12
   


About the InternetOfficer.com Forum

Forum Timezone: UTC 1

Most Users Ever Online: 302

Currently Online:
16 Guests

Currently Browsing this Topic:
1 Guest

Forum Stats:

Groups: 2
Forums: 9
Topics: 638
Posts: 2709

Membership:

There are 257 Members
There have been 302 Guests

There is 1 Admin
There is 1 Moderator

Top Posters:

cssfsu – 55
deepakgupta – 34
albert_newton – 30
cosminpana – 20
DTNMike – 19
ahtshun83 – 17

Recent New Members: raju, todd2taylor, sbdcunha, mansigill1987, ThomasDuh, ThomasKic

Administrators: Jean-Luc (1125 Posts)

Moderators: Jean-Luc (1125 Posts)