Current User: Guest Login
Please consider registering


Lost Your Password?

Search Forums:


 






Minimum search word length is 4 characters – Maximum search word length is 84 characters
Wildcard Usage:
*  matches any number of characters    %  matches exactly one character

trouble with pages crawled by Googlebot

Reply to Post Add a New Topic
UserPost

1:38 am
April 22, 2009


Jacob

Guest

I am having trouble with the code under Pages Crawled by Googlebot. The section does show up in my main awstats.MySite.html but no pagehits are shown. I searched through my log which contains over 100 hits from googlebot. What are my options to search for the error? Does AWstats provide any log files?

Regards,

Jacob

1:44 am
April 22, 2009


Jean-Luc

Admin

posts 1125

Hi,

I am not aware of any problem with the Googlebot version of that extra section.

Do not forget that activating the extra section does not change the data that are already in your AWStats database files. The extra section will be applied to the data in your log file that have not yet been read by AWStats, when you run the next update of the AWStats database.

We recommend that you work with an empty DirData  directory when testing a new extra section. If necessary, temporarily move all files from the DirData  directory to another directory and then update the stats.

10:06 am
April 22, 2009


Jacob

Guest

Hi, and thank you for your answer.

I did work with an empty DirData.

This is an example of the log from IIS:

2009-04-22 14:24:59 GET /xxx.asp – 66.249.65.36 HTTP/1.1 Mozilla/5.0+(compatible;+Googlebot/2.1;++http://www.google.com/bot.html) – 200 29095

Will it work with the ExtrasSection?

I will have to double check that IIS is setup with the right log format and check my AWstats config again. I will get back in a day or two.

/Jacob

3:48 pm
April 22, 2009


Jean-Luc

Admin

posts 1125

You are right. There is a compatibility problem with the format of the user agent used by IIS. The following version should be compatible with both IIS and Apache styles:

ExtraSectionCondition5="UA,^Mozilla\\/5\\.0.\\(compatible;.Googlebot\\/2\\.1;..http\\:\\/\\/www\\.google\\.com\\/bot\\.html\\)$"

I will edit the page with the code example. Thank you for pointing this out.

Reply to Post

Reply to Topic:
trouble with pages crawled by Googlebot

Guest Name (Required):

Guest Email (Required):

NOTE: New Posts are subject to administrator approval before being displayed

Smileys
Confused Cool Cry Embarassed Frown Kiss Laugh Smile Surprised Wink Yell
Post New Reply

Guest URL (required)

Math Required!
What is the sum of:
12 + 7
   


About the InternetOfficer.com Forum

Forum Timezone: UTC 1

Most Users Ever Online: 201

Currently Online:
12 Guests

Currently Browsing this Topic:
1 Guest

Forum Stats:

Groups: 2
Forums: 9
Topics: 638
Posts: 2711

Membership:

There are 257 Members
There have been 304 Guests

There is 1 Admin
There is 1 Moderator

Top Posters:

cssfsu – 55
deepakgupta – 34
albert_newton – 30
cosminpana – 20
DTNMike – 19
ahtshun83 – 17

Recent New Members: raju, todd2taylor, sbdcunha, mansigill1987, ThomasDuh, ThomasKic

Administrators: Jean-Luc (1125 Posts)

Moderators: Jean-Luc (1125 Posts)